Disturbance impacting Skandiabanken
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from Skandiabanken has been resolved.
Posted Oct 14, 2024 - 12:11 CEST
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from Skandiabanken.
Posted Oct 14, 2024 - 11:11 CEST
This incident affected: Ecosystem (Skandiabanken).