Disturbance affecting Swedbank
Incident Report for Swish
Resolved
The disturbance affecting transactions to and from Swedbank has been resolved.
Posted Jun 10, 2024 - 05:39 CEST
Investigating
At the moment, we are experiencing a disturbance affecting transactions to and from Swedbank.
Posted Jun 10, 2024 - 05:36 CEST
This incident affected: Ecosystem (Swedbank).