Disturbance affecting Skandiabanken
Incident Report for Swish
Resolved
The disturbance affecting transactions to and from Skandiabanken has been resolved.
Posted Jul 15, 2024 - 08:48 CEST
Investigating
At the moment, we are experiencing a disturbance affecting transactions to and from Skandiabanken.
Posted Jul 15, 2024 - 06:59 CEST
This incident affected: Ecosystem (Skandiabanken).