Disturbance affecting Marginalen Bank
Incident Report for Swish
Resolved
The disturbance affecting transactions to and from Marginalen Bank has been resolved.
Posted Jun 09, 2024 - 01:30 CEST
Investigating
At the moment, we are experiencing a disturbance affecting transactions to and from Marginalen Bank.
Posted Jun 09, 2024 - 00:10 CEST
This incident affected: Ecosystem (Marginalen Bank).