Disturbance impacting ICA Banken
Incident Report for Swish
Resolved
The disturbance impacting transactions to and from ICA Banken has been resolved.
Posted Sep 25, 2024 - 11:31 CEST
Investigating
At the moment, we are experiencing a disturbance impacting transactions to and from ICA Banken.
Posted Sep 25, 2024 - 11:07 CEST
This incident affected: Ecosystem (ICA Banken).