Disturbance at SEB

Incident Report for Swish

Resolved

The disturbance impacting transactions to and from SEB has been resolved.
Posted 16 days ago. Apr 06, 2025 - 02:47 CEST

Investigating

At the moment, we are experiencing a disturbance impacting transactions to and from SEB.
Posted 16 days ago. Apr 06, 2025 - 02:29 CEST
This incident affected: Ecosystem (SEB).