Disturbance affecting Nordea
Incident Report for Swish
Resolved
The disturbance affecting transactions to and from Nordea has been resolved.
Posted Jul 10, 2024 - 08:49 CEST
Investigating
At the moment, we are experiencing a disturbance affecting transactions to and from Nordea.
Posted Jul 10, 2024 - 07:18 CEST
This incident affected: Ecosystem (Nordea).