Disturbance at Swedbank

Incident Report for Swish

Resolved

The disturbance at Swedbank impacting Swish transactions to and from Swedbank has been resolved.
Posted Sep 26, 2025 - 15:33 CEST

Investigating

At the moment, Swedbank is experiencing a disturbance that may impact Swish transactions to and from Swedbank. For more information and media inquiries, please contact Swedbank. For questions regarding transactions, please contact your bank.
Posted Sep 26, 2025 - 14:52 CEST
This incident affected: Ecosystem (Swedbank).